const regex = /class\s*([a-zA-Z][a-zA-Z\d_\$]*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('class\\s*([a-zA-Z][a-zA-Z\\d_\\$]*)', 'gm')
const str = `class test {
/* class bidule */
class smurf {
}
}
class test3{
}
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}