re = /class\s*([a-zA-Z][a-zA-Z\d_\$]*)/m
str = 'class test {
/* class bidule */
class smurf {
}
}
class test3{
}
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end