import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([0-9]{2})\\/([0-9]{2})\\/([0-9]{4})\\s([0-9]{2}:[0-9]{2}:[0-9]{2})";
final String string = "placeholder_name 01/01/2022 12:00:00 01/01/2022 12:00:01 STATUS 12345/15 50";
final String subst = "\\3\\/\\1\\/\\2 \\4";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}