// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([0-9]{2})\/([0-9]{2})\/([0-9]{4})\s([0-9]{2}:[0-9]{2}:[0-9]{2})").unwrap();
let string = "placeholder_name 01/01/2022 12:00:00 01/01/2022 12:00:01 STATUS 12345/15 50";
let substitution = "\\3\\/\\1\\/\\2 \\4";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}