$re = '/[^a-zA-Z0-9\s]+/m';
$str = '{“23 882 91 317”, “55 672 871 437”, “230 12 435 907”, “320 32 855 107”}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);