re = /[^a-zA-Z0-9\s]+/m
str = '{“23 882 91 317”, “55 672 871 437”, “230 12 435 907”, “320 32 855 107”}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end