using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?:AT\+CIMI|AT\+CPIN|AT\+QCCID|AT\+QSIMSTAT) (?:.+) (\d\d)";
string substitution = @"";
string input = @"6 Network Service Commands .......................................................................................................... 74
6.1. AT+COPS Operator Selection ............................................................................................ 74
6.2. AT+CREG Network Registration ........................................................................................ 76
6.3. AT+CSQ Signal Quality Report .......................................................................................... 78
6.4. AT+CPOL Preferred Operator List ...................................................................................... 79
6.5. AT+COPN Read Operator Names ...................................................................................... 81
6.6. AT+CTZU Automatic Time Zone Update ............................................................................ 81
6.7. AT+CTZR Time Zone Reporting ......................................................................................... 82
6.8. AT+QLTS Obtain the Latest Time Synchronized Through Network .................................... 84
6.9. AT+QNWINFO Query Network Information ........................................................................ 85
6.10. AT+QSPN Display the Name of Registered Network ......................................................... 87";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}