# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?:AT\+CIMI|AT\+CPIN|AT\+QCCID|AT\+QSIMSTAT) (?:.+) (\d\d)"
test_str = ("6 Network Service Commands .......................................................................................................... 74\n"
"6.1. AT+COPS Operator Selection ............................................................................................ 74\n"
"6.2. AT+CREG Network Registration ........................................................................................ 76\n"
"6.3. AT+CSQ Signal Quality Report .......................................................................................... 78\n"
"6.4. AT+CPOL Preferred Operator List ...................................................................................... 79\n"
"6.5. AT+COPN Read Operator Names ...................................................................................... 81\n"
"6.6. AT+CTZU Automatic Time Zone Update ............................................................................ 81\n"
"6.7. AT+CTZR Time Zone Reporting ......................................................................................... 82\n"
"6.8. AT+QLTS Obtain the Latest Time Synchronized Through Network .................................... 84\n"
"6.9. AT+QNWINFO Query Network Information ........................................................................ 85\n"
"6.10. AT+QSPN Display the Name of Registered Network ......................................................... 87")
subst = ""
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.