use strict;
my $str = '6 Network Service Commands .......................................................................................................... 74
6.1. AT+COPS Operator Selection ............................................................................................ 74
6.2. AT+CREG Network Registration ........................................................................................ 76
6.3. AT+CSQ Signal Quality Report .......................................................................................... 78
6.4. AT+CPOL Preferred Operator List ...................................................................................... 79
6.5. AT+COPN Read Operator Names ...................................................................................... 81
6.6. AT+CTZU Automatic Time Zone Update ............................................................................ 81
6.7. AT+CTZR Time Zone Reporting ......................................................................................... 82
6.8. AT+QLTS Obtain the Latest Time Synchronized Through Network .................................... 84
6.9. AT+QNWINFO Query Network Information ........................................................................ 85
6.10. AT+QSPN Display the Name of Registered Network ......................................................... 87';
my $regex = qr/(?:AT\+CIMI|AT\+CPIN|AT\+QCCID|AT\+QSIMSTAT) (?:.+) (\d\d)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";