using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((?>\d))\s(?=\d)";
string substitution = @"$1";
string input = @"Personal Expenses $ 11 4 . 5 6";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}