$re = '/((?>\d))\s(?=\d)/m';
$str = 'Personal Expenses $ 11 4 . 5 6';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;