re = /((?>\d))\s(?=\d)/m
str = 'Personal Expenses $ 11 4 . 5 6'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result