use strict;
my $str = 'Personal Expenses $ 11 4 . 5 6';
my $regex = qr/((?>\d))\s(?=\d)/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";