#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "https:\/\/www\.youtube\.com\/watch\?v=hMZ0Q7Yio8g&list=RDhMZ0Q7Yio8g&start_radio=1"
Local $sString = "https://www.youtube.com/watch?v=hMZ0Q7Yio8g&list=RDhMZ0Q7Yio8g&start_radio=1"
Local $sSubst = "red"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)