const regex = /https:\/\/www\.youtube\.com\/watch\?v=hMZ0Q7Yio8g&list=RDhMZ0Q7Yio8g&start_radio=1/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('https:\\\/\\\/www\\.youtube\\.com\\\/watch\\?v=hMZ0Q7Yio8g&list=RDhMZ0Q7Yio8g&start_radio=1', 'g')
const str = `https://www.youtube.com/watch?v=hMZ0Q7Yio8g&list=RDhMZ0Q7Yio8g&start_radio=1`;
const subst = `red`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);