// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"https:\/\/www\.youtube\.com\/watch\?v=hMZ0Q7Yio8g&list=RDhMZ0Q7Yio8g&start_radio=1").unwrap();
let string = "https://www.youtube.com/watch?v=hMZ0Q7Yio8g&list=RDhMZ0Q7Yio8g&start_radio=1";
let substitution = "red";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}