use strict;
my $str = 'https://www.youtube.com/watch?v=hMZ0Q7Yio8g&list=RDhMZ0Q7Yio8g&start_radio=1';
my $regex = qr/https:\/\/www\.youtube\.com\/watch\?v=hMZ0Q7Yio8g&list=RDhMZ0Q7Yio8g&start_radio=1/p;
my $subst = 'red';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";