using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https:\/\/www\.youtube\.com\/watch\?v=hMZ0Q7Yio8g&list=RDhMZ0Q7Yio8g&start_radio=1";
string substitution = @"red";
string input = @"https://www.youtube.com/watch?v=hMZ0Q7Yio8g&list=RDhMZ0Q7Yio8g&start_radio=1";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}