# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^L_\d\d?_(\d+)$/$1/gm;t' <<< "L_1_3
L_2_23
L_3_91
L_3_16"