$re = '/^L_\d\d?_(\d+)$/m';
$str = 'L_1_3
L_2_23
L_3_91
L_3_16';
$subst = "$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;