use strict;
my $str = 'L_1_3
L_2_23
L_3_91
L_3_16';
my $regex = qr/^L_\d\d?_(\d+)$/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";