import re
regex = re.compile(r"^L_\d\d?_(\d+)$", flags=re.MULTILINE)
test_str = ("L_1_3\n"
"L_2_23\n"
"L_3_91\n"
"L_3_16")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)