using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^L_\d\d?_(\d+)$";
string substitution = @"$1";
string input = @"L_1_3
L_2_23
L_3_91
L_3_16";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}