#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(<img((?!(.*?)class=['\"](.*?)emoji(.*?)['\"](.*?)).)*>)+"
Local $sString = "<img class="emoji">" & @CRLF & _
"<img class="emoji test">" & @CRLF & _
"<img class="test test">" & @CRLF & _
"<img class="test"/>" & @CRLF & _
"<img class="test">" & @CRLF & _
"<img class='test emoji'>" & @CRLF & _
"<img>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")