$re = '/(<img((?!(.*?)class=[\'\"](.*?)emoji(.*?)[\'\"](.*?)).)*>)+/i';
$str = '<img class="emoji">
<img class="emoji test">
<img class="test test">
<img class="test"/>
<img class="test">
<img class=\'test emoji\'>
<img>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);