import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<img((?!(.*?)class=['\\\"](.*?)emoji(.*?)['\\\"](.*?)).)*>)+";
final String string = "<img class=\"emoji\">\n"
+ "<img class=\"emoji test\">\n"
+ "<img class=\"test test\">\n"
+ "<img class=\"test\"/>\n"
+ "<img class=\"test\">\n"
+ "<img class='test emoji'>\n"
+ "<img>";
final Pattern pattern = Pattern.compile(regex, Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}