re = /(<img((?!(.*?)class=['\"](.*?)emoji(.*?)['\"](.*?)).)*>)+/i
str = '<img class="emoji">
<img class="emoji test">
<img class="test test">
<img class="test"/>
<img class="test">
<img class=\'test emoji\'>
<img>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end