using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<img((?!(.*?)class=['\""](.*?)emoji(.*?)['\""](.*?)).)*>)+";
string input = @"<img class=""emoji"">
<img class=""emoji test"">
<img class=""test test"">
<img class=""test""/>
<img class=""test"">
<img class='test emoji'>
<img>";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}