using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^0+\.(?:0+\.)*";
string substitution = @"";
string input = @"0.0.4.1 # 1.
7.51.4.1 # 2.
0.1.4.1 # 3.";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}