import Foundation
let pattern = #"^0+\.(?:0+\.)*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
0.0.4.1 # 1.
7.51.4.1 # 2.
0.1.4.1 # 3.
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)