// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^0+\.(?:0+\.)*").unwrap();
let string = "0.0.4.1 # 1.
7.51.4.1 # 2.
0.1.4.1 # 3.";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}