re = /^0+\.(?:0+\.)*/m
str = '0.0.4.1 # 1.
7.51.4.1 # 2.
0.1.4.1 # 3.'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result