const regex = new RegExp('^0+\\.(?:0+\\.)*', 'gm')
const str = `0.0.4.1 # 1.
7.51.4.1 # 2.
0.1.4.1 # 3.`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);