package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m), [A-Z]{2}`)
var str = `O acumulado no ano, BA ficou em 1,91% e, nos últimos 12 meses, em 4,71%. Em abril de 2018, a taxa havia sido de 0,21%. Os dados foram divulgados hoje pelo IBGE (Instituto Brasileiro de Geografia e Estatística).... - Veja mais em `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}