import Foundation
let pattern = #", [A-Z]{2}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"O acumulado no ano, BA ficou em 1,91% e, nos últimos 12 meses, em 4,71%. Em abril de 2018, a taxa havia sido de 0,21%. Os dados foram divulgados hoje pelo IBGE (Instituto Brasileiro de Geografia e Estatística).... - Veja mais em "#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)