$re = '/, [A-Z]{2}/m';
$str = 'O acumulado no ano, BA ficou em 1,91% e, nos últimos 12 meses, em 4,71%. Em abril de 2018, a taxa havia sido de 0,21%. Os dados foram divulgados hoje pelo IBGE (Instituto Brasileiro de Geografia e Estatística).... - Veja mais em ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);