use strict;
my $str = 'O acumulado no ano, BA ficou em 1,91% e, nos últimos 12 meses, em 4,71%. Em abril de 2018, a taxa havia sido de 0,21%. Os dados foram divulgados hoje pelo IBGE (Instituto Brasileiro de Geografia e Estatística).... - Veja mais em ';
my $regex = qr/, [A-Z]{2}/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}