import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^[^\\W_]+(?:[-_.][^\\W_]+){0,3}$";
final String string = "exampletag\n"
+ "example-tag\n"
+ "ex-ample-tag\n"
+ "ex_ample_tag\n"
+ "ex-ample_tag\n"
+ "ex.am-ple_tag\n"
+ "Ex.4m-p1e_t4g\n\n"
+ "ex-am-pl-et-ag\n"
+ " // and variations where there's more than 3 `-` `_` or `.`\n"
+ "-exampletag\n"
+ " // no starting symbols\n"
+ "exampletag-\n"
+ " // no trailing symbols";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}