# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[^\W_]+(?:[-_.][^\W_]+){0,3}$"
test_str = ("exampletag\n"
"example-tag\n"
"ex-ample-tag\n"
"ex_ample_tag\n"
"ex-ample_tag\n"
"ex.am-ple_tag\n"
"Ex.4m-p1e_t4g\n\n"
"ex-am-pl-et-ag\n"
" // and variations where there's more than 3 `-` `_` or `.`\n"
"-exampletag\n"
" // no starting symbols\n"
"exampletag-\n"
" // no trailing symbols")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.