re = /^[^\W_]+(?:[-_.][^\W_]+){0,3}$/m
str = 'exampletag
example-tag
ex-ample-tag
ex_ample_tag
ex-ample_tag
ex.am-ple_tag
Ex.4m-p1e_t4g
ex-am-pl-et-ag
// and variations where there\'s more than 3 `-` `_` or `.`
-exampletag
// no starting symbols
exampletag-
// no trailing symbols'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end