const regex = /^[^\W_]+(?:[-_.][^\W_]+){0,3}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^[^\\W_]+(?:[-_.][^\\W_]+){0,3}$', 'gm')
const str = `exampletag
example-tag
ex-ample-tag
ex_ample_tag
ex-ample_tag
ex.am-ple_tag
Ex.4m-p1e_t4g
ex-am-pl-et-ag
// and variations where there's more than 3 \`-\` \`_\` or \`.\`
-exampletag
// no starting symbols
exampletag-
// no trailing symbols`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}