import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = " (\\w\\w\\w) (\\1)$";
final String string = "A Nightmare On Elm Street 720p Bluray X264-Pahe In mkv mkv\n"
+ "Austin Powers International Man Of Mystery 480p Bluray 300mb-Pahe In mkv mkv\n"
+ "Death_warrant_1990_720p_bluray_x264_750mb-Pahe In mkv mkv\n"
+ "Die Frau Des Polizisten 720p Bluray X264-Pahe In mkv mkv";
final String subst = ".\\1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}