# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/<(\s*[+-]?[0-9])/<$1/gm;t' <<< "<p>I am <30 years old and weight <12st I am < 30 years old and weight < 12st I am <30 years old and weight < -12st I am < +30 years old and weight < 12st</p>"