$re = '/<(\s*[+-]?[0-9])/m';
$str = '<p>I am <30 years old and weight <12st I am < 30 years old and weight < 12st I am <30 years old and weight < -12st I am < +30 years old and weight < 12st</p>';
$subst = "<$1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;