use strict;
my $str = '<p>I am <30 years old and weight <12st I am < 30 years old and weight < 12st I am <30 years old and weight < -12st I am < +30 years old and weight < 12st</p>';
my $regex = qr/<(\s*[+-]?[0-9])/mp;
my $subst = '<$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";