const regex = /<(\s*[+-]?[0-9])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<(\\s*[+-]?[0-9])', 'gm')
const str = `<p>I am <30 years old and weight <12st I am < 30 years old and weight < 12st I am <30 years old and weight < -12st I am < +30 years old and weight < 12st</p>`;
const subst = `<$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);