package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<(\s*[+-]?[0-9])`)
var str = `<p>I am <30 years old and weight <12st I am < 30 years old and weight < 12st I am <30 years old and weight < -12st I am < +30 years old and weight < 12st</p>`
var substitution = "<$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}