#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\d{2}){1,2}$"
Local $sString = "00" & @CRLF & _
"01" & @CRLF & _
"11" & @CRLF & _
"99" & @CRLF & _
"2020" & @CRLF & _
"3000" & @CRLF & _
"3021" & @CRLF & _
"" & @CRLF & _
"1" & @CRLF & _
"123" & @CRLF & _
"43221" & @CRLF & _
"215467"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")