import re
regex = re.compile(r"^(\d{2}){1,2}$", flags=re.MULTILINE)
test_str = ("00\n"
"01\n"
"11\n"
"99\n"
"2020\n"
"3000\n"
"3021\n\n"
"1\n"
"123\n"
"43221\n"
"215467")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")