$re = '/^(\d{2}){1,2}$/m';
$str = '00
01
11
99
2020
3000
3021
1
123
43221
215467';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);